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Lesson 10 -Lesson 10 -
The Picture ControlThe Picture Control

In this lesson you'll learn how to utilize the Picture control of Visual Basic.

Create the Directory of the MyBird Program, Start Visual
Basic 4, and Save the Form and the Project Files
In this lesson you are going to create several files. So first of all, let's create a
directory where the files that you'll create during the course of this lesson are
saved.

 Create the C:\VBMyProg\Lesson10 directory.

 Start Visual Basic, and then select New Project from the File menu
of Visual Basic.

 Select Project from the View menu of Visual Basic to display the
Project window. Click the View Form button of the Project window to
make Form1 the selected form.

 While Form1 is the selected window, select Save File As from the
File menu of Visual Basic.

Visual Basic responds by displaying the Save File As dialog box.
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 Save the Form file as MyBird.frm inside the
C:\VBMyProg\Lesson10 directory.

 Select Save Project As from the File menu of Visual Basic.

Visual Basic responds by displaying the Save Project As dialog box.

 Save the project file as MyBird.vbp inside the
C:\VBMyProg\Lesson10 directory.

Set the Properties of Form1
You'll now set the properties of Form1.

 Make the Form1 window the selected window, and then press the
F4 key on your keyboard to display the Properties window of Form1.

 Set the properties of Form1 as follows:

Property Setting

Name frmMyBird

Caption The MyBird Program

Height 3570

Width 3885

BackColor White

 Select Save Project from the File menu of Visual Basic to save your
work.

Implementing the Exit button
You'll now place the Exit button inside the frmMyBird form.
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 Make sure that the frmMyBird form is the selected window, and then
double-click the CommandButton icon inside the Toolbox window.

 Make the CommandButton that you placed inside the from the
selected object, press F4 on your keyboard to display the Properties
window, and then set the properties of the CommandButton as follows:

Property Setting

Name cmdExit

Caption E&xit

Height 495

Width 1215

Top 2520

Left 1200

 Double click the cmdExit button to display the Code window, set the
Object list box of the Code window to cmdExit, set the Proc list box of
the Code window to Click, and then type the following code inside the
cmdExit_Click() procedure:

Private Sub cmdExit_Click()

    End

End Sub

 Select Save project from the File menu of Visual Basic to save your
work.

The code that you typed is executed automatically whenever the user clicks the
Exit button. This code causes the program to terminate itself.

Placing the Picture Control
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You'll now place the Picture control inside the frmMyBird form.

The icon of the Picture control is shown as the icon on the first row on the right
column in the Toolbox of Figure 10.1. But in your Toolbox, the icon of the Picture
control may be locates in a different place inside your Toolbox window.

Figure 10.1. The icon of the Picture control inside the Toolbox window.

NOTE
When you place (without clicking) the mouse cursor on the Picture
control, a yellow rectangle pops up with the text PictureBox in it.

 Make sure that the frmMyBird form is the selected window, and then
double click the Picture control inside the Toolbox.

Visual Basic responds by placing the Picture control inside the frmMyBird
form.
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 Set the Picture property of the Picture control that you placed inside
the frmMyBird form to load the Bird0.BMP picture that resides inside the
\TegoVB4\VBMyProg\BMP directory. (That is, click inside the cell that is
located to the right of the Picture property, click the three dot icon, and
then use the Load Picture dialog box to load the BMP picture).

Now the Picture control has the Bird0.BMP picture in it (see Figure 10.2.)

Figure 10.2. A portion of the Bird0.BMP picture is displayed inside the Picture
control.

As shown in Figure 10.2,  only a portion of the Bird0.BMP picture is displayed.
Why? Because currently, the size of the Picture control is not large enough to
contain the entire BMP picture.

The AutoSize Property of the Picture
Control
Recall that the Image control has the Stretch property. When you set the
Stretch property of the Image control to False, the size of the Image control is
automatically changed so that the entire BMP picture is displayed. However, the
Picture control does not have a Stretch property. The Picture control has the
AutoSize property.
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 Set the AutoSize property of the Picture control that you placed
inside the frmMyBird form to True.

Visual Basic responds by changing the size of the Picture control so that
the control will display the entire BMP picture.

 Drag the Picture control a little bit upward so that the picture will not
be placed over the Exit button.

 Select Save Project from the File menu of Visual Basic to save your
work.

 Select Start from the Run menu of Visual Basic to execute the
MyBird program.

The window of the MyBird program appears as shown in Figure 10.3.

Figure 10.3. The entire BMP picture is displayed inside the Picture
control.

 Click the Exit button of the MyBird program to terminate the
program.
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The BorderStyle Property
The reason the BMP picture has a frame around it, is because currently the
BorderStyle property of the Picture control that you placed inside the frmMyBird
form is set to 1-Fixed Single. If you set the BorderStyle property of the Picture
control to 0-None, you'll see the BMP picture inside the Picture control as shown
in Figure 10.4 (without frame).

Figure 10.4. The Picture control of the MyBird program when the BorderStyle is
set to 0-None.

Removing the Picture
Here is how you remove the BMP picture from the Picture control:

 Make the Picture control the selected object, then press F4 to
display the Properties windows of the Picture control.

As you can see, the Picture property has the text (Bitmap) in it.

 Double click the text (Bitmap) that appears in the cell to the right of
the Picture property, and then press the Delete key of your keyboard.

Visual Basic responds by deleting the BMP picture.
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The Align Property of the Picture Control
So far, you did not see any significant differences between the Image control and
the Picture control.

The main difference between the Image control and the Picture control is the fact
that the Picture control has the Align property. This is discussed in detailed in
the next lesson.

What You Accomplished in This Lesson

You completed Lesson 10 of the Self Study Visual Basic tutorial.

The MyBird program that you implemented in this lesson demonstrates how to
use the Picture control for displaying BMP pictures.

Frequently Asked Questions

Q1.  Why do I need the Picture control? It looks as if it performs the same
function as the Image control.

A1.  As will be demonstrated in the next lesson, the Picture control has
the Align property, and this property enables you to implement toolbars
and status bars with great ease.

Exam
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1.  To change the size of the Picture control so that the entire BMP picture
will fit inside the Picture control you have to:

(a) Set the AutoSize property of the Picture control to True.

(b) Set the Stretch property of the Picture control to True.

(c) Set the Stretch property of the Picture control to False.

2.  The BorderStyle of the Picture control is used for setting the:

(a) Frame (border) of the picture.

(b) Size of the BMP picture.

Answers to Exam

1. (a) To change the size of the Picture control so that the entire BMP
picture will fit inside the Picture control you have to set the AutoSize
property of the Picture control to True. The Picture control does not have
a Stretch property.

2.  (a) The BorderStyle of the Picture control is used for setting the frame
(border) of the picture.

Project
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Modify the MyBird program so that whenever the user double clicks the bird, a
message box appears.

 In design mode, double click the Picture control to display the Code
window, set the Object list box to Picture1 (Picture1 is the Name
property of the Picture control that you placed inside the form), and set
the Proc list box to DblClick.

Visual Basic responds by displaying the Picture1_DblClick() procedure
ready to be edited by you as follows:

Private Sub Picture1_DblClick()

End Sub

The DblClick event occurs whenever the user double clicks the object. (As it
turns out, many controls support the DblClick event).

 Type the following code inside the Picture1_DblCLick() procedure:

Private Sub Picture1_DblClick()

    MsgBox "You double clicked the bird"

End Sub

 Select Save Project from the File menu of Visual Basic to Execute
the MyBird program.
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The window of the MyBird program appears with the picture of the bird in
it.

 Double click the bird.

As you can see, a message box appears. That is, once you double click
the Picture control, the DblClick event occurs, which means that the
Picture1_DblClick() procedure is executed automatically. The code that
you typed inside the Picture1_DblClick() procedure displays the
message box.

How To Contact TegoSoft

You can contact TegoSoft Inc. by any one of the following methods:

 Use TegoSoft Internet Web site:

http://www.tegosoft.com

 Send TegoSoft an e-mail:

tegosoft@msn.com

 Send TegoSoft a letter:

TegoSoft Inc.

P.O.Box 389

Bellmore, NY 11710

USA

Technical Support
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If you have a technical question, you can post the question to the TegoSoft
Technical Support staff, and they will try to answer your question.

The best way to post a technical question is by sending TegoSoft an e-mail.

 The e-mail of  TegoSoft is:

tegosoft@msn.com

When sending TegoSoft an e-mail with a technical question, please follow
the following format:

                               Date:  ________________

                     Your name:  ________________

 Company (if applicable):  ________________

       Your phone number:  ________________

                    Your e-mail:  ________________

   Country (if not USA):  ________________

    State (if inside USA):  ________________

                      Operating System used:  __________

 Programming language and version :  __________

My technical question is:

Copyright © and Notices
Copyright © 1994, 1995, 1996 by TegoSoft Inc. ® All Rights Reserved
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Although precaution was taken in the preparation of this document,
TegoSoft assumes no responsibility for errors or omissions. TegoSoft is
not liable for damages resulting from the use of the information contained
in this document. Use this document at your own risk. This document is
copyright protected. This means that you should treat this document like
any other copyright material. No part of this document should be copied in
any way. You are not allowed to use this document or any part of this
document for any purpose other than read it. You are not allowed to
publish this document or any part of this document in any way. You are
not allowed to sell this document or any part of this document, you are not
allowed to incorporate this document or any part of this document in any
book, magazine, Web Site, Electronic forums, disks, CDs, or any other
media. The only thing that you are allowed to do with this document is
read it for the sole purpose of studying the material that is presented in
this document. If this document includes software, the software must be
treated in the exact same way that this document is treated. You are not
allowed to distribute the software in any way. The sole purpose of
supplying the accompanying software is to enable you to experience with
it. No part of this document should be modified. If accompanying software
is included with this document, you are not allowed to modify the
software.
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