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Lesson 9 -Lesson 9 -
Displaying ImagesDisplaying Images

In this lesson you'll learn how to incorporate pictures into your programs.

Create the Directory of the MyImage Program, Start
Visual Basic 4, and Save the Form and the Project Files
In this lesson you are going to create several files. So first of all, let's create a
directory where the files that you'll create during the course of this lesson are
saved.

 Create the C:\VBMyProg\Lesson09 directory.

 Start Visual Basic, and then select New Project from the File menu
of Visual Basic.

 Select Project from the View menu of Visual Basic to display the
Project window. Click the View Form button of the Project window to
make Form1 the selected form.

  While Form1 is the selected window, select Save File As from the
File menu of Visual Basic.

Visual Basic responds by displaying the Save File As dialog box.
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 Save the Form file as MyImage.frm inside the
C:\VBMyProg\Lesson09 directory.

 Select Save Project As from the File menu of Visual Basic.

Visual Basic responds by displaying the Save Project As dialog box.

 Save the project file as MyImage.vbp inside the
C:\VBMyProg\Lesson09 directory.

Set the Properties of Form1
You'll now set the properties of Form1.

 Make the Form1 window the selected window, and then press the
F4 key on your keyboard to display the Properties window of Form1.

 Set the properties of Form1 as follows:

Property Setting

Name frmMyImage

Caption The MyImage Program

Height 3570

Width 3885

BackColor White

 Select Save Project from the File menu of Visual Basic to save your
work.

Implementing the Exit button
You'll now place the Exit button inside the frmMyImage form.
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 Make sure that the frmMyImage form is the selected window, and
then double-click the CommandButton icon inside the Toolbox window.

 Make the CommandButton that you placed inside the from the
selected object, press F4 on your keyboard to display the Properties
window, and then set the properties of the CommandButton as follows:

Property Setting

Name cmdExit

Caption E&xit

Height 495

Width 1215

Top 2520

Left 1200

 Double click the cmdExit button to display the Code window, set the
Object list box of the Code window to cmdExit, set the Proc list box of
the Code window to Click, and then type the following code inside the
cmdExit_Click() procedure:

Private Sub cmdExit_Click()

    End

End Sub

 Select Save project from the File menu of Visual Basic to save your
work.

The code that you typed is executed automatically whenever the user clicks the
Exit button. This code causes the program to terminate itself.
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Placing the Image Control
You'll now place the Image control inside the frmMyImage form.

The icon of the Image control inside the Toolbox is shown in Figure 9.1. In
Figure 9.1 the icon of the Image is shown on the left column as the second icon
from the bottom. But in your Toolbox, the icon of the Image tool may be located
in a different location inside your Toolbox window.

Figure 9.1. The icon of the Image control inside the Toolbox window.

NOTE
When you place the mouse cursor (without clicking) on the Image tool
inside the Toolbox window, a yellow rectangle with the text Image
appears.

 Make sure that the frmMyImage form is the selected window, and
then double click the Image control inside the Toolbox window.
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Visual Basic responds by placing the Image control inside the
frmMyImage form (see Figure 9.2).

Figure 9.2. The form with the Image control in it.

Setting the Picture Property of the
Image Control
The Image control is used for displaying images. In particular, you set the
Picture property of the Image control with the picture that you want to display.
Here is how you set the Picture property of the Image control:

 Click the Image control that you placed inside the form to make it the
selected object, and then press the F4 key to display the Properties
window of the Image control.

Currently, the cell to the right of the Picture property has the text (None)
in it (that's why currently the Image control does not have any picture in
it).

 Click inside the cell to the right of the Picture property, and then click
the three dots icon that appears inside the cell to the right of the Picture
property.
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Visual Basic responds by displaying the Load Picture dialog box.

 Use the Load Picture dialog box to load a picture file. The picture
file can be a BMP file for example. The Files of type list box that is
located at the lower portion of the Load Picture dialog box lets you select
different types of picture files. For now, set the Files of type list box to All
Picture Files, and select a BMP picture. For example, you can select the
Bird0.BMP picture that resides inside the C:\TegoVB4\VBMyProg\BMP
directory.

Visual Basic responds by filling the Image control with the picture of the
Bird0.BMP file.

 Drag the Image control upward so that the form will look as shown in
Figure 9.3.

Figure 9.3. The Image control contains the Bird0.BMP picture.

NOTE
Note that by default, the Image control automatically changed its size so
that the size of the Image control has the same as the Bird0.BMP picture.
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The reason the Image control did not stretch the BMP picture to fit the
picture in the original size of the Image control is because one of the
properties of the Image control is the Stretch property, and the default
value of this property is False. If you set the Stretch property of the
Image control to True, the BMP picture will be stretched/shrinked to fit
inside the original area of the Image control.

Let's see the MyImage program in action:

 Select Start from the Run menu of Visual Basic.

Visual Basic responds by executing the MyImage program, and the
window of the program appears as shown in Figure 9.4.

Figure 9.4. The MyImage program with the Bird0.BMP picture in it.

 Click the Exit button of the MyImage program to terminate the
program.

What You Accomplished in This
Lesson
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You completed Lesson 9 of the Self Study Visual Basic tutorial.

The MyImage program that you implemented in this lesson demonstrates how to
use the Image control for displaying images.

Frequently Asked Questions

Q1. When I set the Picture property of the Image control, I see that I can
set the Picture control to a BMP files, Metafiles, and Icon files. What are
these files?

A1. Yes, when you use the Load Picture dialog box to set the Picture
property of the Image control, you can see that you can load these
different picture file formats.

A BMP picture (called a bitmap picture) is a file that has the BMP file
extension (as in Bird0.BMP). You can draw something with the Paint
program (or Paintbrush program), and then save the picture as a BMP
file. In a BMP file, each pixel of the picture has a corresponding number in
the BMP file. That number represents the color of the pixel. At the
beginning of the BMP file there is a group of numbers that indicates the
size of the picture, the number of colors that the picture uses, and other
important information about the picture. But the majority of the file is
composed of numbers where each number represents a pixel in the
picture, hence the name Bitmap (where the bits and bytes are basically
the map of the picture).

A Metafile is also a file that contains a picture. However, unlike the BMP
picture, the Metafile contains instructions that represent the way the
picture should be drawn, For example, the instruction can be: draw a
black line from a certain coordinates in the picture to another coordinates
in the picture. Some drawing programs lets you save your drawings as
Metafiles.
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An Icon file is a picture file that contains a small picture. Theses small
pictures are used for example as program icons. A program icon file has
the file extension ICO as in MyIcon.ICO.

An icon file can also represent the picture that is used for the mouse
cursor. In this case, the file has the file extension CUR as in
MyCursor.CUR.

You need a special program to generate ICO and CUR files.

In any case, you can use the Load Picture dialog box to load a BMP
picture, a metafile picture, or an Icon picture.

Exam

1.  When the Stretch property of the Image control is set to False:

 

(a)  The BMP picture will stretched/shrinked itself to fit inside the
original size of the Image control.

(b) The BMP picture will not be stretched. Rather, the BMP picture
will be shown in its original size, and the Image control will
automatically adjust its own size so that the Image control has the
same size of the original BMP picture.

Answers to Exam
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1.  (b) When the Stretch property of the Image control is set to False, the
BMP picture will not be stretched/shrinked. Rather, the BMP picture
will be shown in its original size, and the Image control will
automatically adjust its own size so that the Image control has the
same size of the original BMP picture. If you want the BMP picture to
stretched/shrinked so that the picture will fit in the original size of the
Image control, set the Stretched property to True.

Project

Currently, the image that is displayed by the MyImage program does not have a
frame around the picture. Modify the MyImage program so that the Bird0.BMP
picture will have a frame around it.

The preceding is very easy to implement as follows:

 Set the BorderStyle property of the Image control that you placed
inside the form to: 1- Fixed Single

 Select Save Project from the File menu of Visual Basic to save your
work.

 Select Start from the Run menu of Visual Basic to execute the
MyImage program.

The window of the MyImage program now looks as shown in Figure 9.5.
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Figure 9.5. The MyImage program with the BorderStyle property of the Image
control set to 1-Fixed Single.

 Click the Exit button to terminate the program.

Now modify the MyImage program so that the Bird picture will appear smaller:

 Set the Stretch property of the Image control to True.

 Use the mouse to drag the edges of the Image control to make it
smaller.

 Select Start from the Run menu of Visual Basic.

Visual Basic responds by executing the MyImage program, and the
window of the MyImage program looks as shown in Figure 9.6.
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Figure 9.6. The Image control with a shrinked version of the Bird picture in it.

The Name property that Visual Basic set for the Image control that you placed
inside the form is Image1 (you can verify this by examining the Name property of
the image control inside the Properties window).

The Image control has all the "standard" properties and events that most
controls have. Let's see this in action. In particular, let's see the Click event of
the Image control in action:

 Double click the Image1 control that you placed inside the form to
display the Code window. Set the Object list box to Image1, and set the
Proc list box to Click.

Visual Basic responds by displaying the Image1_Click() procedure as
follows:

Private Sub Image1_Click()

End Sub

 Type the following code inside the Image1_Click() procedure:

Private Sub Image1_Click()
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    MsgBox "You clicked the bird"

End Sub

 Select Save Project from the File menu of Visual Basic to save your
work.

The Image1_Click() procedure is automatically executed whenever the image is
clicked. The code that you typed inside the Image1_Click() procedure displays a
message box that has the in it the text: You clicked the bird.

 Select Start from the Run menu of Visual Basic to execute the
MyImage program.

 Click the bird picture and notice the message box that pops up.

 Experiment with the MyImage program, and then click its Exit button
to terminate the program.

How To Contact TegoSoft

You can contact TegoSoft Inc. by any one of the following methods:

 Use TegoSoft Internet Web site:

http://www.tegosoft.com

 Send TegoSoft an e-mail:

tegosoft@msn.com

 Send TegoSoft a letter:
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TegoSoft Inc.

P.O.Box 389

Bellmore, NY 11710

USA

Technical Support

If you have a technical question, you can post the question to the TegoSoft
Technical Support staff, and they will try to answer your question.

The best way to post a technical question is by sending TegoSoft an e-mail.

 The e-mail of  TegoSoft is:

tegosoft@msn.com

When sending TegoSoft an e-mail with a technical question, please follow
the following format:

                               Date:  ________________

                     Your name:  ________________

 Company (if applicable):  ________________

       Your phone number:  ________________

                    Your e-mail:  ________________

      Country (if not USA):  ________________

      State (if inside USA):  ________________

                      Operating System used:  __________

 Programming language and version :  __________
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My technical question is:

Copyright © and Notices
Copyright © 1994, 1995, 1996 by TegoSoft Inc. ® All Rights Reserved

TegoSoft Self Study Tutorials & Software

Copyright ©1994, 1995, 1996 by TegoSoft Inc. ® All Rights Reserved

Although precaution was taken in the preparation of this document,
TegoSoft assumes no responsibility for errors or omissions. TegoSoft is
not liable for damages resulting from the use of the information contained
in this document. Use this document at your own risk. This document is
copyright protected. This means that you should treat this document like
any other copyright material. No part of this document should be copied in
any way. You are not allowed to use this document or any part of this
document for any purpose other than read it. You are not allowed to
publish this document or any part of this document in any way. You are
not allowed to sell this document or any part of this document, you are not
allowed to incorporate this document or any part of this document in any
book, magazine, Web Site, Electronic forums, disks, CDs, or any other
media. The only thing that you are allowed to do with this document is
read it for the sole purpose of studying the material that is presented in
this document. If this document includes software, the software must be
treated in the exact same way that this document is treated. You are not
allowed to distribute the software in any way. The sole purpose of
supplying the accompanying software is to enable you to experience with
it. No part of this document should be modified. If accompanying software
is included with this document, you are not allowed to modify the
software.
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